Back to overview
Maintenance

Site-Wide Maintenance

May 8, 2026 at 12:30pm UTC  –  May 9, 2026 at 12:30am UTC
Affected services
Node 1
Node 2
Node 3
Node 4
Node 5
Node 6
Node 7
bayhosting.pro
panel.bayhosting.pro
cdn.bayhosting.pro
jelly.bayhosting.pro

Resolved
May 9, 2026 at 12:30am UTC

Maintenance complete.

Created
May 8, 2026 at 12:30pm UTC

All Services will be unreachable from 7am - 5pm (PDT) on May 8th due to on-going system upgrades. Please contact our support team with any questions or concerns.